Console Output

+ ./gradlew build -xtest
Downloading https://services.gradle.org/distributions/gradle-6.7.1-bin.zip
.........10%..........20%..........30%..........40%..........50%.........60%..........70%..........80%..........90%..........100%

Welcome to Gradle 6.7.1!

Here are the highlights of this release:
 - File system watching is ready for production use
 - Declare the version of Java your build requires
 - Java 15 support

For more details see https://docs.gradle.org/6.7.1/release-notes.html

Starting a Gradle Daemon (subsequent builds will be faster)
> Task :compileJava
> Task :plugin-xml
> Task :processResources
> Task :classes
> Task :jar
> Task :javadoc
> Task :javadocJar

> Task :openapi
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.

> Task :nodeSetup

> Task :yarnSetup
/tmp/workspace/ger-plugins_scm-cas-plugin_PR-29/.gradle/yarn/yarn-v1.22.5/bin/yarn -> /tmp/workspace/ger-plugins_scm-cas-plugin_PR-29/.gradle/yarn/yarn-v1.22.5/lib/node_modules/yarn/bin/yarn.js
/tmp/workspace/ger-plugins_scm-cas-plugin_PR-29/.gradle/yarn/yarn-v1.22.5/bin/yarnpkg -> /tmp/workspace/ger-plugins_scm-cas-plugin_PR-29/.gradle/yarn/yarn-v1.22.5/lib/node_modules/yarn/bin/yarn.js
+ yarn@1.22.5
added 1 package in 0.362s

> Task :yarn_install
yarn install v1.22.5
[1/4] Resolving packages...
[2/4] Fetching packages...
warning webpack-plugin-serve@1.3.0: Invalid bin field for "webpack-plugin-serve".
info fsevents@2.3.2: The platform "linux" is incompatible with this module.
info "fsevents@2.3.2" is an optional dependency and failed compatibility check. Excluding it from installation.
info fsevents@1.2.13: The platform "linux" is incompatible with this module.
info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
warning " > react-i18next@10.13.2" has unmet peer dependency "i18next@>= 17.0.0".
warning " > react-redux@5.1.2" has incorrect peer dependency "react@^0.14.0 || ^15.0.0-0 || ^16.0.0-0".
warning " > styled-components@5.2.1" has unmet peer dependency "react-dom@>= 16.8.0".
warning " > styled-components@5.2.1" has unmet peer dependency "react-is@>= 16.8.0".
warning "@scm-manager/ui-plugins > @scm-manager/ui-components > react-diff-view@2.4.7" has unmet peer dependency "prop-types@>=15.6".
warning "@scm-manager/ui-plugins > @scm-manager/ui-components > react-select@2.4.4" has incorrect peer dependency "react@^15.3.0 || ^16.0.0".
warning "@scm-manager/ui-plugins > @scm-manager/ui-components > react-select@2.4.4" has incorrect peer dependency "react-dom@^15.3.0 || ^16.0.0".
warning "@scm-manager/ui-plugins > @scm-manager/ui-components > react-select > react-input-autosize@2.2.2" has incorrect peer dependency "react@^0.14.9 || ^15.3.0 || ^16.0.0-rc || ^16.0".
warning "@scm-manager/eslint-config > @typescript-eslint/eslint-plugin@2.34.0" has incorrect peer dependency "eslint@^5.0.0 || ^6.0.0".
warning "@scm-manager/eslint-config > @typescript-eslint/parser@2.34.0" has incorrect peer dependency "eslint@^5.0.0 || ^6.0.0".
warning "@scm-manager/eslint-config > eslint-config-react-app@5.2.1" has incorrect peer dependency "eslint@6.x".
warning "@scm-manager/eslint-config > eslint-plugin-prettier@3.3.1" has unmet peer dependency "prettier@>=1.13.0".
warning "@scm-manager/eslint-config > eslint-plugin-react-hooks@2.5.1" has incorrect peer dependency "eslint@^3.0.0 || ^4.0.0 || ^5.0.0 || ^6.0.0".
warning "@scm-manager/eslint-config > @typescript-eslint/eslint-plugin > tsutils@3.20.0" has unmet peer dependency "typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta".
warning "@scm-manager/jest-preset > babel-jest@26.6.3" has unmet peer dependency "@babel/core@^7.0.0".
warning "@scm-manager/ui-scripts > @pmmmwh/react-refresh-webpack-plugin@0.4.3" has incorrect peer dependency "react-refresh@>=0.8.3 <0.10.0".
warning "@scm-manager/ui-scripts > babel-loader@8.2.2" has unmet peer dependency "@babel/core@^7.0.0".
warning "@scm-manager/ui-tests > @wojtekmaj/enzyme-adapter-react-17@0.6.3" has unmet peer dependency "react-dom@^17.0.0-0".
warning "@scm-manager/ui-tests > enzyme-context-react-router-4@2.1.0" has unmet peer dependency "react-router@4.x || 5.x".
warning Workspaces can only be enabled in private projects.
[4/4] Building fresh packages...
$ plugin-scripts postinstall
Done in 77.27s.

> Task :ui-bundle
yarn run v1.22.5
$ plugin-scripts build
Hash: 6dd10850f1ab0bd442f7
Version: webpack 4.46.0
Time: 2643ms
Built at: 10/06/2021 6:24:41 AM
                   Asset      Size  Chunks             Chunk Names
scm-cas-plugin.bundle.js  36.5 KiB       0  [emitted]  scm-cas-plugin
Entrypoint scm-cas-plugin = scm-cas-plugin.bundle.js
[0] external "react" 42 bytes {0} [built]
[1] external "@scm-manager/ui-components" 42 bytes {0} [built]
[2] external "react-i18next" 42 bytes {0} [built]
[3] external "@scm-manager/ui-extensions" 42 bytes {0} [built]
[4] multi ./node_modules/@scm-manager/plugin-scripts/src/webpack-public-path.js ./src/main/js/index.ts 40 bytes {0} [built]
[5] ./node_modules/@scm-manager/plugin-scripts/src/webpack-public-path.js 1.4 KiB {0} [built]
[6] ./src/main/js/index.ts + 3 modules 11.6 KiB {0} [built]
    | ./src/main/js/index.ts 1.59 KiB [built]
    | ./src/main/js/GlobalCasConfiguration.tsx 2.59 KiB [built]
    | ./src/main/js/CasLoginLink.tsx 1.48 KiB [built]
    | ./src/main/js/GlobalCasConfigurationForm.tsx 5.87 KiB [built]
Done in 4.06s.

> Task :smp
> Task :release-yaml
> Task :sourcesJar
> Task :assemble
> Task :licenseBuild UP-TO-DATE
> Task :licenseMain UP-TO-DATE
> Task :licenseTest UP-TO-DATE
> Task :licenseUI UP-TO-DATE
> Task :license UP-TO-DATE

> Task :validate
[INFO ] Rule passed: gradle and package.json names are equal
[INFO ] Rule passed: version of gradle.properties and package.json are equal
[INFO ] Rule passed: scm version is equal with @scm-manager/ui-plugins
[INFO ] Rule passed: package.json uses post install of plugin-scripts
[INFO ] Rule passed: no plugin dependencies with min-version condition found

> Task :validatePluginJson
> Task :check
> Task :build

Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/6.7.1/userguide/command_line_interface.html#sec:command_line_warnings

BUILD SUCCESSFUL in 2m 48s
20 actionable tasks: 16 executed, 4 up-to-date